#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ">((\-|\+)?[0-9]+(\.[0-9]+)?)<"
Local $sString = "fhah<dfsd>ssd<sdfds" & @CRLF & _
"234>+0.34<4534" & @CRLF & _
"f44r>-234<dfr4" & @CRLF & _
"34>+18<de"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")