$re = '/>((\-|\+)?[0-9]+(\.[0-9]+)?)</';
$str = 'fhah<dfsd>ssd<sdfds
234>+0.34<4534
f44r>-234<dfr4
34>+18<de';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);