re = />((\-|\+)?[0-9]+(\.[0-9]+)?)</
str = 'fhah<dfsd>ssd<sdfds
234>+0.34<4534
f44r>-234<dfr4
34>+18<de'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end