const regex = />((\-|\+)?[0-9]+(\.[0-9]+)?)</g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('>((\\-|\\+)?[0-9]+(\\.[0-9]+)?)<', 'g')
const str = `fhah<dfsd>ssd<sdfds
234>+0.34<4534
f44r>-234<dfr4
34>+18<de`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}