package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`>((\-|\+)?[0-9]+(\.[0-9]+)?)<`)
var str = `fhah<dfsd>ssd<sdfds
234>+0.34<4534
f44r>-234<dfr4
34>+18<de`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}