using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">((\-|\+)?[0-9]+(\.[0-9]+)?)<";
string input = @"fhah<dfsd>ssd<sdfds
234>+0.34<4534
f44r>-234<dfr4
34>+18<de";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}