# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<![^\/])(?!\.\.(?![^\/]))[^\/]+\/\.\.(?:\/|$)//gm;t' <<< "\"folders/folder1/folder5/../../folder2\" -> \"folders/folder2\"
\"folders/folder1/../../../folder2\" -> \"../folder2\"
\"folders/folder1/folder5/../folder2\" -> \"folders/folder1/folder2\""