using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![^/])(?!\.\.(?![^/]))[^/]+/\.\.(?:/|$)";
string substitution = @"";
string input = @"""folders/folder1/folder5/../../folder2"" -> ""folders/folder2""
""folders/folder1/../../../folder2"" -> ""../folder2""
""folders/folder1/folder5/../folder2"" -> ""folders/folder1/folder2""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}