#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<![^/])(?!\.\.(?![^/]))[^/]+/\.\.(?:/|$)"
Local $sString = ""folders/folder1/folder5/../../folder2" -> "folders/folder2"" & @CRLF & _
"" & @CRLF & _
""folders/folder1/../../../folder2" -> "../folder2"" & @CRLF & _
"" & @CRLF & _
""folders/folder1/folder5/../folder2" -> "folders/folder1/folder2""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)