re = /(?<![^\/])(?!\.\.(?![^\/]))[^\/]+\/\.\.(?:\/|$)/m
str = '"folders/folder1/folder5/../../folder2" -> "folders/folder2"
"folders/folder1/../../../folder2" -> "../folder2"
"folders/folder1/folder5/../folder2" -> "folders/folder1/folder2"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result