const regex = new RegExp('(?<![^/])(?!\\.\\.(?![^/]))[^/]+/\\.\\.(?:/|$)', 'gm')
const str = `"folders/folder1/folder5/../../folder2" -> "folders/folder2"
"folders/folder1/../../../folder2" -> "../folder2"
"folders/folder1/folder5/../folder2" -> "folders/folder1/folder2"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);