import re
regex = re.compile(r"(?<![^/])(?!\.\.(?![^/]))[^/]+/\.\.(?:/|$)", flags=re.MULTILINE)
test_str = ("\"folders/folder1/folder5/../../folder2\" -> \"folders/folder2\"\n\n"
"\"folders/folder1/../../../folder2\" -> \"../folder2\"\n\n"
"\"folders/folder1/folder5/../folder2\" -> \"folders/folder1/folder2\"")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)