#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?=[a-zA-Z])(?=[A-Z])"
Local $sString = "thisIsASuperTest" & @CRLF & _
"AnotherTest" & @CRLF & _
"dont-get-me-started" & @CRLF & _
"HahahAHahHAHAHaHA"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)