import Foundation
let pattern = #"(?=[a-zA-Z])(?=[A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
thisIsASuperTest
AnotherTest
dont-get-me-started
HahahAHahHAHAHaHA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)