re = /(?=[a-zA-Z])(?=[A-Z])/
str = 'thisIsASuperTest
AnotherTest
dont-get-me-started
HahahAHahHAHAHaHA'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result