const regex = /(?=[a-zA-Z])(?=[A-Z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=[a-zA-Z])(?=[A-Z])', 'g')
const str = `thisIsASuperTest
AnotherTest
dont-get-me-started
HahahAHahHAHAHaHA`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);