using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=[a-zA-Z])(?=[A-Z])";
string substitution = @"-";
string input = @"thisIsASuperTest
AnotherTest
dont-get-me-started
HahahAHahHAHAHaHA";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}