use strict;
my $str = 'thisIsASuperTest
AnotherTest
dont-get-me-started
HahahAHahHAHAHaHA';
my $regex = qr/(?=[a-zA-Z])(?=[A-Z])/p;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";