const regex = /(Test results for mic0\n)( Test .+: passed\n){9}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Test results for mic0\\n)( Test .+: passed\\n){9}', 'gm')
const str = `http://sid-buildstore.pdx.intel.com/mpss-4/4.4/ci/MPSS-4-CI-4.4.0.3110/eng/internal/rhel7.2/test/rhel7.2/x86_64/systools_test-4.4.0-3110.x86_64.rpm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}