use strict;
my $str = 'http://sid-buildstore.pdx.intel.com/mpss-4/4.4/ci/MPSS-4-CI-4.4.0.3110/eng/internal/rhel7.2/test/rhel7.2/x86_64/systools_test-4.4.0-3110.x86_64.rpm';
my $regex = qr/(Test results for mic0\n)( Test .+: passed\n){9}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}