# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.{10})(.{6})(.{5})(.*)/$1$3$2$4/gm;t' <<< "Abcdef_ghi_12_15_2021_(Regular)_-_Complete.xlsx"