package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.{10})(.{6})(.{5})(.*)`)
var str = `Abcdef_ghi_12_15_2021_(Regular)_-_Complete.xlsx`
var substitution = "$1$3$2$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}