#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.{10})(.{6})(.{5})(.*)"
Local $sString = "Abcdef_ghi_12_15_2021_(Regular)_-_Complete.xlsx"
Local $sSubst = "$1$3$2$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)