use strict;
my $str = 'Abcdef_ghi_12_15_2021_(Regular)_-_Complete.xlsx';
my $regex = qr/^(.{10})(.{6})(.{5})(.*)/mp;
my $subst = '$1$3$2$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";