$re = '/^(.{10})(.{6})(.{5})(.*)/m';
$str = 'Abcdef_ghi_12_15_2021_(Regular)_-_Complete.xlsx';
$subst = "$1$3$2$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;