using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.{10})(.{6})(.{5})(.*)";
string substitution = @"$1$3$2$4";
string input = @"Abcdef_ghi_12_15_2021_(Regular)_-_Complete.xlsx";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}