#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?su)<h3>(.+?)\<\/h3>\s*<h4>(.+)<\/h4>\s*<dl>\s*<dt>(.+)<\/dt>\s*<dd>(.+)<\/dd>"
Local $sString = "<h3>Z's(矢沢永吉)</h3>" & @CRLF & _
" <h4>Z's TOUR 2015</h4>" & @CRLF & _
"" & @CRLF & _
" <dl>" & @CRLF & _
" <dt><img src="/event/img/btn_day.png" alt="公演日時" width="92" height="20"> </dt>" & @CRLF & _
" <dd>" & @CRLF & _
" <table width="99%" border="0" cellpadding="0" cellspacing="0">" & @CRLF & _
" <tbody><tr>" & @CRLF & _
" <td width="9%" nowrap="nowrap">2015年6月</td>" & @CRLF & _
" <td width="74%">4日 (木) 19:00開演</td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" </tbody></table>" & @CRLF & _
" </dd>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")