use strict;
my $str = '<h3>Z\'s(矢沢永吉)</h3>
<h4>Z\'s TOUR 2015</h4>
<dl>
<dt><img src="/event/img/btn_day.png" alt="公演日時" width="92" height="20"> </dt>
<dd>
<table width="99%" border="0" cellpadding="0" cellspacing="0">
<tbody><tr>
<td width="9%" nowrap="nowrap">2015年6月</td>
<td width="74%">4日 (木) 19:00開演</td>
</tr>
</tbody></table>
</dd>';
my $regex = qr/<h3>(.+?)\<\/h3>\s*<h4>(.+)<\/h4>\s*<dl>\s*<dt>(.+)<\/dt>\s*<dd>(.+)<\/dd>/sup;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}