$re = '/<h3>(.+?)\<\/h3>\s*<h4>(.+)<\/h4>\s*<dl>\s*<dt>(.+)<\/dt>\s*<dd>(.+)<\/dd>/su';
$str = '<h3>Z\'s(矢沢永吉)</h3>
<h4>Z\'s TOUR 2015</h4>
<dl>
<dt><img src="/event/img/btn_day.png" alt="公演日時" width="92" height="20"> </dt>
<dd>
<table width="99%" border="0" cellpadding="0" cellspacing="0">
<tbody><tr>
<td width="9%" nowrap="nowrap">2015年6月</td>
<td width="74%">4日 (木) 19:00開演</td>
</tr>
</tbody></table>
</dd>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);