# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:\G(?!^)|\(\) => import\(\/\*)[^\/*]*)\//$1--/gm;t' <<< "() => import(/* webpackChunkName: \"components/something/Something\" */ '@/components/something/Something')
with
() => import(/* webpackChunkName: \"components--something--Something\" */ '@/components/something/Something')"