$re = '~((?:\G(?!^)|\(\) => import\(/\*)[^/*]*)/~m';
$str = '() => import(/* webpackChunkName: "components/something/Something" */ \'@/components/something/Something\')
with
() => import(/* webpackChunkName: "components--something--Something" */ \'@/components/something/Something\')';
$subst = "$1--";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;