re = /((?:\G(?!^)|\(\) => import\(\/\*)[^\/*]*)\//m
str = '() => import(/* webpackChunkName: "components/something/Something" */ \'@/components/something/Something\')
with
() => import(/* webpackChunkName: "components--something--Something" */ \'@/components/something/Something\')'
subst = '$1--'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result