use strict;
my $str = '() => import(/* webpackChunkName: "components/something/Something" */ \'@/components/something/Something\')
with
() => import(/* webpackChunkName: "components--something--Something" */ \'@/components/something/Something\')';
my $regex = qr~((?:\G(?!^)|\(\) => import\(/\*)[^/*]*)/~mp;
my $subst = '$1--';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";