#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:\G(?!^)|\(\) => import\(/\*)[^/*]*)/"
Local $sString = "() => import(/* webpackChunkName: "components/something/Something" */ '@/components/something/Something')" & @CRLF & _
"" & @CRLF & _
"with" & @CRLF & _
"" & @CRLF & _
"() => import(/* webpackChunkName: "components--something--Something" */ '@/components/something/Something')"
Local $sSubst = "$1--"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)