const regex = /(?<!£)\b(\d+)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!£)\\b(\\d+)\\b', 'g')
const str = `1-10
10-20-30
500-600-800
£500`;
const subst = `£$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);