import re
regex = re.compile(r"(?<!£)\b(\d+)\b")
test_str = ("1-10\n"
"10-20-30\n"
"500-600-800\n"
"£500")
subst = "£$1"
result = regex.sub(subst, test_str)
if result:
print(result)