re = /(?<!£)\b(\d+)\b/
str = '1-10
10-20-30
500-600-800
£500'
subst = '£$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result