using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(([^""]*""){2})*[^""]*$)Dogs";
string substitution = @"Cats";
string input = @"Dogs are scary but my mom told me that ""Dogs are cute""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}