re = /(?=(([^"]*"){2})*[^"]*$)Dogs/
str = 'Dogs are scary but my mom told me that "Dogs are cute"'
subst = 'Cats'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result