import Foundation
let pattern = #"(?=(([^"]*"){2})*[^"]*$)Dogs"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Dogs are scary but my mom told me that "Dogs are cute""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Cats"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)