$re = '/(?=(([^"]*"){2})*[^"]*$)Dogs/';
$str = 'Dogs are scary but my mom told me that "Dogs are cute"';
$subst = "Cats";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;