import re
regex = re.compile(r"(?=(([^\"]*\"){2})*[^\"]*$)Dogs")
test_str = "Dogs are scary but my mom told me that \"Dogs are cute\""
subst = "Cats"
result = regex.sub(subst, test_str)
if result:
print(result)