using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<host>[\d\.]+)\s(?P<identity>\S*)\s(?P<user>\S*)\s\[(?P<time>.*?)\]\s""(?P<request>.*?)""\s(?P<status>\d+)\s(?P<bytes>\S*)";
string input = @"10.223.157.186 - - [15/Jul/2009:15:50:36 -0700] ""GET /assets/img/dummy/secondary-news-3.jpg HTTP/1.1"" 200 5604";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}