import Foundation
let pattern = #"(?P<host>[\d\.]+)\s(?P<identity>\S*)\s(?P<user>\S*)\s\[(?P<time>.*?)\]\s"(?P<request>.*?)"\s(?P<status>\d+)\s(?P<bytes>\S*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"10.223.157.186 - - [15/Jul/2009:15:50:36 -0700] "GET /assets/img/dummy/secondary-news-3.jpg HTTP/1.1" 200 5604"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}