use strict;
my $str = '10.223.157.186 - - [15/Jul/2009:15:50:36 -0700] "GET /assets/img/dummy/secondary-news-3.jpg HTTP/1.1" 200 5604';
my $regex = qr/(?P<host>[\d\.]+)\s(?P<identity>\S*)\s(?P<user>\S*)\s\[(?P<time>.*?)\]\s"(?P<request>.*?)"\s(?P<status>\d+)\s(?P<bytes>\S*)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}