const regex = new RegExp('(?P<host>[\\d\\.]+)\\s(?P<identity>\\S*)\\s(?P<user>\\S*)\\s\\[(?P<time>.*?)\\]\\s"(?P<request>.*?)"\\s(?P<status>\\d+)\\s(?P<bytes>\\S*)', '')
const str = `10.223.157.186 - - [15/Jul/2009:15:50:36 -0700] "GET /assets/img/dummy/secondary-news-3.jpg HTTP/1.1" 200 5604`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}