import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<host>[\\d\\.]+)\\s(?P<identity>\\S*)\\s(?P<user>\\S*)\\s\\[(?P<time>.*?)\\]\\s\"(?P<request>.*?)\"\\s(?P<status>\\d+)\\s(?P<bytes>\\S*)";
final String string = "10.223.157.186 - - [15/Jul/2009:15:50:36 -0700] \"GET /assets/img/dummy/secondary-news-3.jpg HTTP/1.1\" 200 5604";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}