re = /(?P<host>[\d\.]+)\s(?P<identity>\S*)\s(?P<user>\S*)\s\[(?P<time>.*?)\]\s"(?P<request>.*?)"\s(?P<status>\d+)\s(?P<bytes>\S*)/
str = '10.223.157.186 - - [15/Jul/2009:15:50:36 -0700] "GET /assets/img/dummy/secondary-news-3.jpg HTTP/1.1" 200 5604'
# Print the match result
str.match(re) do |match|
puts match.to_s
end