# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\bcopy\b)[\s\S]*?(?=\s*\bfrom\b)//gm;t' <<< "copy table values from 'a.dat';"