const regex = new RegExp('(?<=\\bcopy\\b)[\\s\\S]*?(?=\\s*\\bfrom\\b)', 'gm')
const str = `copy table values from 'a.dat';`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);